Rise is intermittently slow
Incident Report for Rise
Resolved
We've confirmed that Rise is performing normally. Sorry for the disruption.
Posted Jan 19, 2022 - 14:22 UTC
Monitoring
Rise is running normally now. We're monitoring to make sure it's resolved.
Posted Jan 19, 2022 - 07:46 UTC
Investigating
Rise is intermittently slow, and we’re looking into what went wrong. We’ll let you know as soon as we have more info. We’re so sorry for the trouble.
Posted Jan 19, 2022 - 07:24 UTC
This incident affected: Rise.com Website and Rise Blog.