Signing Up for New Trials Causes an Error
Incident Report for Rise
Resolved
Signing up for a new trial is working normally again. We apologize for any trouble!
Posted Dec 02, 2021 - 17:01 UTC
Investigating
Signing up for a new trial causes an error, and we're investigating the problem. You can get around the error by going directly to your subdomain at .rise.com. We're sorry for the trouble, and we'll keep you posted!
Posted Dec 02, 2021 - 15:46 UTC
This incident affected: Rise (Authentication).