Rise.com: Intermittent access

Incident Report for Rise

Resolved

This incident has been resolved. Rise.com is fully operational.
Posted Nov 04, 2025 - 19:20 UTC

Monitoring

We’re investigating intermittent issues that may block access to Rise.com. Some users may have trouble logging in or staying connected.
We’ve made an update and are watching closely to confirm stability.
Posted Nov 03, 2025 - 21:17 UTC
This incident affected: Rise.com Website.