On November 19, our third-party authentication provider applied a platform upgrade to our production environment. This change introduced unexpected authentication behavior that caused some users to be unable to sign in, and it also delayed certain automated provisioning tasks. After identifying the upgrade as the source of the issue, we worked with the provider to revert the change. Service was fully restored once the rollback was completed.
Incident Details and Timeline of Events
Impact:
Some users were unable to sign in or were met with unexpected login prompts.
A small number of organizations saw delays in SCIM imports
Timeline:
November 18 15:00 UTC — Our third-party authentication provider applied a platform upgrade to our production environment.
November 18 15:22 UTC — Monitoring detected degraded performance for SCIM imports and activated our triage team.
November 18 19:00 UTC — We received reports of sign-in issues.
November 18 20:05 - 20:35 UTC — We identified the issue as the third-party authentication provider’s upgrade and worked with them to roll it back. Our first public status was posted.
November 18 22:21 UTC — Rollback completes. Most systems recovered. We continued to closely monitoring.
November 19 00:07 UTC — Confirmed full recovery after final checks. Incident closed.
What We’re Improving
Strengthening how we monitor and handle upgrade notices from third-party providers to prevent uncoordinated changes.
Enhancing early detection for authentication anomalies to surface issues sooner.
Refining our internal response workflows to ensure faster engagement during emerging incidents.
Posted Nov 21, 2025 - 17:41 UTC
Resolved
This incident has been resolved.
Posted Nov 19, 2025 - 00:07 UTC
Monitoring
We’ve fixed the issue, and users should now be able to sign in and access their accounts. We’ll continue to monitor the situation to ensure everything remains stable. Thanks for your patience!
Posted Nov 18, 2025 - 22:37 UTC
Identified
We’ve made changes to our systems and are starting to see improvements. Many users can now log into Rise.com successfully.
We’re continuing to monitor closely and will keep sharing updates until everyone can successfully log in.
Posted Nov 18, 2025 - 21:37 UTC
Investigating
We're currently investigating an issue affecting Rise.com sign-ins. Some users are prompted to answer a security question unexpectedly or caught in a sign-in loop and unable to access their accounts We’ll share more as we learn more. Thanks for bearing with us while we look into it.