Rise.com: Issue with Unauthorized Prompt Appearing for some Customers Based on Timezone
Incident Report for Rise
Postmortem

On August 10, 2022, the Articulate team made an inadvertent change to Rise.com and Rise 360 that caused users in Russian time zones to receive a pop up message that redirected their browser to a third party website.

What Happened

On August 10, 2022 at 12:02 pm ET, the Articulate team made a change to Rise 360 and Rise.com that upgraded a specific third party library that included an unauthorized modification.

On August 11, 2022 at 9:16 am ET customers alerted us to the issue. At 11:58 am ET the change was reverted and shipped to Rise 360 and Rise.com.

In Rise.com the impact of this incident was limited to users who were actively engaged in a course and had their browser set to a Russian time zone between August 10, 2022, 12:02 pm ET and August 11, 2022, 11:58 am ET. In Rise 360, courses exported and published in an LMS during this period will continue to display the pop up message to users with a Russian time zone setting until the course is replaced by a newly exported course.

What We’re Doing About It

Following the removal of the upgraded library from our repositories, we locked our dependency on that specific third party library to a known uncompromised version to prevent this specific issue from occurring again. In the long term, we will migrate our codebase away from this library and improve our auditing of third party libraries to ensure ongoing safety in our software dependencies.

Customer security and trust is a top priority and we continually work to improve our engineering and quality processes to maintain that trust. For more information on how we protect our customers, please visit https://articulate.com/trust. If you have any further questions, please create a case and our support team will follow up.

Posted Aug 23, 2022 - 21:06 UTC

Resolved
This issue is now resolved. Rise users should refresh their browser while viewing a course to no longer see the prompt.
Posted Aug 11, 2022 - 16:55 UTC
Investigating
Our team is investigating an issue where some users are seeing a prompt in Russian that directs them to a 3rd party website while viewing a Rise course. We're working to resolve the issue ASAP.
Posted Aug 11, 2022 - 15:10 UTC
This incident affected: Rise (Learning, Authoring).